Bug 1948636 (CVE-2021-30152) - CVE-2021-30152 mediawiki: action=protect lets users with 'protect' permission protect to higher protection level
Summary: CVE-2021-30152 mediawiki: action=protect lets users with 'protect' permission...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-30152
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1949572 1949574 1947340 1948637
Blocks: 1948646
TreeView+ depends on / blocked
 
Reported: 2021-04-12 16:29 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 08:50 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.12, mediawiki 1.35.2
Doc Type: If docs needed, set a value
Doc Text:
In mediawiki package when using API to protect a page, user with "protect" permission can protect the page to a higher level than they can edit.
Clone Of:
Environment:
Last Closed: 2021-10-28 08:50:31 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-04-12 16:29:22 UTC
An issue was discovered in MediaWiki before 1.31.13 and 1.32.x through 1.35.x before 1.35.2. When using the MediaWiki API to "protect" a page, a user is currently able to protect to a higher level than they currently have permissions for.

Reference:
https://phabricator.wikimedia.org/T270713

Comment 1 Guilherme de Almeida Suckevicz 2021-04-12 16:29:53 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1948637]

Comment 3 Przemyslaw Roguski 2021-04-13 09:11:40 UTC
Statement:

The mediawiki package was removed from OpenShift Container Platform (OCP) in version 4.3, therefore for OCP 4 has been marked as out of support scope.


Note You need to log in before you can comment on or make changes to this bug.