Bug 1948641 (CVE-2021-30155) - CVE-2021-30155 mediawiki: ContentModelChange does not check if a user has correct permissions to create and set the content model of a nonexistent page
Summary: CVE-2021-30155 mediawiki: ContentModelChange does not check if a user has cor...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-30155
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1947340 1948642
Blocks: 1948646
TreeView+ depends on / blocked
 
Reported: 2021-04-12 16:39 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 08:51 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.12, mediawiki 1.35.2
Doc Type: If docs needed, set a value
Doc Text:
In the mediawiki package, a user can create new page even if it matches [[MediaWiki:Titleblacklist]] restriction when using [[Special:ChangeContentModel]].
Clone Of:
Environment:
Last Closed: 2021-10-28 08:51:00 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-04-12 16:39:08 UTC
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. ContentModelChange does not check if a user has correct permissions to create and set the content model of a nonexistent page.

Reference:
https://phabricator.wikimedia.org/T270988

Comment 1 Guilherme de Almeida Suckevicz 2021-04-12 16:40:16 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1948642]

Comment 2 Przemyslaw Roguski 2021-04-13 10:46:29 UTC
Statement:

The mediawiki package was removed from OpenShift Container Platform (OCP) in version 4.3, therefore for OCP 4 has been marked as out of support scope.


Note You need to log in before you can comment on or make changes to this bug.