Bug 1946692 (CVE-2021-30157) - CVE-2021-30157 mediawiki: XSS due to unescaped messages used in HTML on ChangesList pages
Summary: CVE-2021-30157 mediawiki: XSS due to unescaped messages used in HTML on Chang...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-30157
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1947420 1947421 1946693 1947340
Blocks: 1946702
TreeView+ depends on / blocked
 
Reported: 2021-04-06 16:55 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 08:49 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.12, mediawiki 1.35.2
Doc Type: If docs needed, set a value
Doc Text:
In mediawiki package on ChangesList special pages such as Special:RecentChanges and Special:Watchlist, some of the rcfilters-filter-* label messages are outputted in HTML unescaped, which could leading to Cross-site Scripting (XSS).
Clone Of:
Environment:
Last Closed: 2021-10-28 08:49:42 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-04-06 16:55:32 UTC
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. On ChangesList special pages such as Special:RecentChanges and Special:Watchlist, some of the rcfilters-filter-* label messages are output in HTML unescaped, leading to XSS.

Reference:
https://phabricator.wikimedia.org/T278058

Comment 1 Guilherme de Almeida Suckevicz 2021-04-06 16:55:50 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1946693]

Comment 3 Przemyslaw Roguski 2021-04-07 13:15:00 UTC
External References:

https://phabricator.wikimedia.org/T278058

Comment 4 Przemyslaw Roguski 2021-04-08 09:16:04 UTC
Statement:

The mediawiki package was removed from OpenShift Container Platform (OCP) in version 4.3, therefore for OCP 4 has been marked as out of support scope.


Note You need to log in before you can comment on or make changes to this bug.