Bug 1946698 (CVE-2021-30158) - CVE-2021-30158 mediawiki: blocked users are unable to use Special:ResetTokens
Summary: CVE-2021-30158 mediawiki: blocked users are unable to use Special:ResetTokens
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-30158
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1946699 1947340
Blocks: 1946702
TreeView+ depends on / blocked
 
Reported: 2021-04-06 17:07 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-10-28 08:50 UTC (History)
11 users (show)

Fixed In Version: mediawiki 1.31.12, mediawiki 1.35.2
Doc Type: If docs needed, set a value
Doc Text:
In mediawiki a blocked users are not able to use Special:ResetTokens. If such user shared a token (accidentally or not) then it wasn't possible to block any potential future use of the compromised token.
Clone Of:
Environment:
Last Closed: 2021-10-28 08:50:14 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-04-06 17:07:50 UTC
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. Blocked users are unable to use Special:ResetTokens. This has security relevance because a blocked user might have accidentally shared a token, or might know that a token has been compromised, and yet is not able to block any potential future use of the token by an unauthorized party.

Reference:
https://phabricator.wikimedia.org/T277009

Comment 1 Guilherme de Almeida Suckevicz 2021-04-06 17:08:32 UTC
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1946699]

Comment 3 Przemyslaw Roguski 2021-04-07 13:29:18 UTC
External References:

https://phabricator.wikimedia.org/T277009

Comment 4 Przemyslaw Roguski 2021-04-08 09:16:14 UTC
Statement:

The mediawiki package was removed from OpenShift Container Platform (OCP) in version 4.3, therefore for OCP 4 has been marked as out of support scope.


Note You need to log in before you can comment on or make changes to this bug.