Bug 1986898 (CVE-2021-30762) - CVE-2021-30762 webkitgtk: Use-after-free leading to arbitrary code execution
Summary: CVE-2021-30762 webkitgtk: Use-after-free leading to arbitrary code execution
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-30762
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1877119 1877358 1986899
Blocks: 1986910
TreeView+ depends on / blocked
 
Reported: 2021-07-28 13:46 UTC by Michael Kaplan
Modified: 2021-08-30 23:57 UTC (History)
4 users (show)

Fixed In Version: webkitgtk 2.28.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 23:57:28 UTC


Attachments (Terms of Use)

Description Michael Kaplan 2021-07-28 13:46:57 UTC
A use after free issue was addressed with improved memory management.

Comment 1 Michael Kaplan 2021-07-28 13:47:31 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 1986899]

Comment 2 Tomas Hoger 2021-08-30 14:48:43 UTC
Upstream advisory:

https://webkitgtk.org/security/WSA-2021-0004.html

Comment 3 Tomas Hoger 2021-08-30 20:06:37 UTC
According to WebKitGTK upstream advisory, this issue was fixed upstream in version 2.28.0.  The webkitgtk4 packages in Red Hat Enterprise Linux 6 and webkit2gtk3 packages in Red Hat Enterprise Linux 8 were previously updated to fixed upstream versions via the following errata:

https://access.redhat.com/errata/RHSA-2020:4035
https://access.redhat.com/errata/RHSA-2020:4451

Comment 4 Product Security DevOps Team 2021-08-30 23:57:28 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-30762


Note You need to log in before you can comment on or make changes to this bug.