Bug 2011017 (CVE-2021-32626) - CVE-2021-32626 redis: Lua scripts can overflow the heap-based Lua stack [NEEDINFO]
Summary: CVE-2021-32626 redis: Lua scripts can overflow the heap-based Lua stack
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-32626
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2011569 2012217 2015079 2015875 2011214 2011561 2011562 2011563 2011564 2011565 2011566 2011567 2011568 2011570 2011592 2011645 2011663 2011743 2012216 2012364 2012365 2013313 2013314 2015874
Blocks: 2011061
TreeView+ depends on / blocked
 
Reported: 2021-10-05 18:47 UTC by Pedro Sampaio
Modified: 2022-01-13 22:08 UTC (History)
56 users (show)

Fixed In Version: redis 6.2.6, redis 6.0.16, redis 5.0.14
Doc Type: If docs needed, set a value
Doc Text:
A heap buffer overflow was found in redis. Specially crafted Lua scripts executing in Redis cause the heap-based Lua stack to overflow due to incomplete checks for this condition. This flaw allows a remote attacker to corrupt the heap and potentially trigger remote code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-10-15 02:08:54 UTC
jawerner: needinfo? (astrouse)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:3953 0 None None None 2021-10-25 01:19:12 UTC
Red Hat Product Errata RHBA-2021:3997 0 None None None 2021-10-26 13:01:11 UTC
Red Hat Product Errata RHBA-2021:4001 0 None None None 2021-10-26 16:46:25 UTC
Red Hat Product Errata RHSA-2021:3873 0 None None None 2021-10-14 22:39:15 UTC
Red Hat Product Errata RHSA-2021:3918 0 None None None 2021-10-19 13:40:03 UTC
Red Hat Product Errata RHSA-2021:3925 0 None None None 2021-10-20 03:55:32 UTC
Red Hat Product Errata RHSA-2021:3944 0 None None None 2021-10-20 13:53:59 UTC
Red Hat Product Errata RHSA-2021:3945 0 None None None 2021-10-20 14:15:39 UTC
Red Hat Product Errata RHSA-2021:3946 0 None None None 2021-10-20 13:56:43 UTC
Red Hat Product Errata RHSA-2021:3947 0 None None None 2021-10-20 13:51:53 UTC
Red Hat Product Errata RHSA-2021:3949 0 None None None 2021-10-20 19:44:58 UTC
Red Hat Product Errata RHSA-2021:3971 0 None None None 2021-10-25 13:17:38 UTC
Red Hat Product Errata RHSA-2021:3980 0 None None None 2021-10-25 17:56:32 UTC
Red Hat Product Errata RHSA-2021:4618 0 None None None 2021-11-11 18:32:52 UTC

Description Pedro Sampaio 2021-10-05 18:47:02 UTC
Redis is an open source, in-memory database that persists on disk. In affected versions specially crafted Lua scripts executing in Redis can cause the heap-based Lua stack to be overflowed, due to incomplete checks for this condition. This can result with heap corruption and potentially remote code execution. This problem exists in all versions of Redis with Lua scripting support, starting from 2.6. The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14. For users unable to update an additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.

References:

https://github.com/redis/redis/commit/666ed7facf4524bf6d19b11b20faa2cf93fdf591
https://github.com/redis/redis/security/advisories/GHSA-p486-xggp-782c

Comment 7 Mauro Matteo Cascella 2021-10-08 15:05:22 UTC
Created redis tracking bugs for this issue:

Affects: epel-7 [bug 2012217]
Affects: fedora-all [bug 2012216]

Comment 10 errata-xmlrpc 2021-10-14 22:39:13 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 7

Via RHSA-2021:3873 https://access.redhat.com/errata/RHSA-2021:3873

Comment 11 Product Security DevOps Team 2021-10-15 02:08:54 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-32626

Comment 14 errata-xmlrpc 2021-10-19 13:40:00 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:3918 https://access.redhat.com/errata/RHSA-2021:3918

Comment 15 errata-xmlrpc 2021-10-20 03:55:30 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.3 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.3 for RHEL 7

Via RHSA-2021:3925 https://access.redhat.com/errata/RHSA-2021:3925

Comment 17 errata-xmlrpc 2021-10-20 13:51:50 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.7 EUS

Via RHSA-2021:3947 https://access.redhat.com/errata/RHSA-2021:3947

Comment 18 errata-xmlrpc 2021-10-20 13:53:56 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:3944 https://access.redhat.com/errata/RHSA-2021:3944

Comment 19 errata-xmlrpc 2021-10-20 13:56:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:3946 https://access.redhat.com/errata/RHSA-2021:3946

Comment 20 errata-xmlrpc 2021-10-20 14:15:36 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:3945 https://access.redhat.com/errata/RHSA-2021:3945

Comment 22 errata-xmlrpc 2021-10-20 19:44:56 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.1 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.1 for RHEL 7

Via RHSA-2021:3949 https://access.redhat.com/errata/RHSA-2021:3949

Comment 23 errata-xmlrpc 2021-10-25 13:17:35 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 10.0 (Newton)

Via RHSA-2021:3971 https://access.redhat.com/errata/RHSA-2021:3971

Comment 24 errata-xmlrpc 2021-10-25 17:56:30 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 13.0 - ELS
  Red Hat OpenStack Platform 13.0 (Queens) for RHEL 7.6 EUS

Via RHSA-2021:3980 https://access.redhat.com/errata/RHSA-2021:3980

Comment 25 errata-xmlrpc 2021-11-11 18:32:49 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.4 for RHEL 8

Via RHSA-2021:4618 https://access.redhat.com/errata/RHSA-2021:4618

Comment 27 Jan Werner 2022-01-13 22:08:58 UTC
Can you please comment on:
https://redhat.service-now.com/surl.do?n=INC2052240


Note You need to log in before you can comment on or make changes to this bug.