Bug 2010991 (CVE-2021-32687) - CVE-2021-32687 redis: Integer overflow issue with intsets
Summary: CVE-2021-32687 redis: Integer overflow issue with intsets
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-32687
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2012211 2011195 2011477 2011478 2011479 2011480 2011481 2011482 2011483 2011484 2011485 2011486 2011589 2011638 2011663 2011740 2012210 2012383 2012384 2013308 2013309
Blocks: 2011061
TreeView+ depends on / blocked
 
Reported: 2021-10-05 17:59 UTC by Pedro Sampaio
Modified: 2022-05-17 09:54 UTC (History)
54 users (show)

Fixed In Version: redis 6.2.6, redis 6.0.16, redis 5.0.14
Doc Type: If docs needed, set a value
Doc Text:
An integer overflow issue was found in redis. The vulnerability involves changing the default "set-max-intset-entries" configuration parameter to a very large value and constructing specially crafted commands to manipulate sets. This flaw allows a remote attacker to leak arbitrary contents of the heap or potentially trigger remote code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-10-15 02:08:23 UTC
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:3953 0 None None None 2021-10-25 01:19:08 UTC
Red Hat Product Errata RHBA-2021:3997 0 None None None 2021-10-26 13:01:04 UTC
Red Hat Product Errata RHBA-2021:4001 0 None None None 2021-10-26 16:46:19 UTC
Red Hat Product Errata RHSA-2021:3873 0 None None None 2021-10-14 22:39:00 UTC
Red Hat Product Errata RHSA-2021:3918 0 None None None 2021-10-19 13:39:54 UTC
Red Hat Product Errata RHSA-2021:3925 0 None None None 2021-10-20 03:55:19 UTC
Red Hat Product Errata RHSA-2021:3944 0 None None None 2021-10-20 13:53:46 UTC
Red Hat Product Errata RHSA-2021:3945 0 None None None 2021-10-20 14:15:23 UTC
Red Hat Product Errata RHSA-2021:3946 0 None None None 2021-10-20 13:56:28 UTC
Red Hat Product Errata RHSA-2021:3947 0 None None None 2021-10-20 13:51:38 UTC
Red Hat Product Errata RHSA-2021:3949 0 None None None 2021-10-20 19:44:52 UTC
Red Hat Product Errata RHSA-2021:3971 0 None None None 2021-10-25 13:17:30 UTC
Red Hat Product Errata RHSA-2021:3980 0 None None None 2021-10-25 17:56:24 UTC
Red Hat Product Errata RHSA-2021:4618 0 None None None 2021-11-11 18:32:35 UTC

Description Pedro Sampaio 2021-10-05 17:59:10 UTC
Redis is an open source, in-memory database that persists on disk. An integer overflow bug affecting all versions of Redis can be exploited to corrupt the heap and potentially be used to leak arbitrary contents of the heap or trigger remote code execution. The vulnerability involves changing the default set-max-intset-entries configuration parameter to a very large value and constructing specially crafted commands to manipulate sets. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the set-max-intset-entries configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.

References:

https://github.com/redis/redis/security/advisories/GHSA-m3mf-8x9w-r27q
https://github.com/redis/redis/commit/a30d367a71b7017581cf1ca104242a3c644dec0f

Comment 8 Tapas Jena 2021-10-11 16:14:36 UTC
Analysis is complete for Ansible components and its found that neither the affected Redis version nor the affected functionality is in use in any Ansible components.Hence, marking all the Ansible components as not affected.

Comment 10 errata-xmlrpc 2021-10-14 22:38:58 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.2 for RHEL 7

Via RHSA-2021:3873 https://access.redhat.com/errata/RHSA-2021:3873

Comment 11 Product Security DevOps Team 2021-10-15 02:08:23 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-32687

Comment 13 errata-xmlrpc 2021-10-19 13:39:51 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:3918 https://access.redhat.com/errata/RHSA-2021:3918

Comment 14 errata-xmlrpc 2021-10-20 03:55:16 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.3 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.3 for RHEL 7

Via RHSA-2021:3925 https://access.redhat.com/errata/RHSA-2021:3925

Comment 15 errata-xmlrpc 2021-10-20 13:51:34 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.7 EUS

Via RHSA-2021:3947 https://access.redhat.com/errata/RHSA-2021:3947

Comment 16 errata-xmlrpc 2021-10-20 13:53:42 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:3944 https://access.redhat.com/errata/RHSA-2021:3944

Comment 17 errata-xmlrpc 2021-10-20 13:56:25 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:3946 https://access.redhat.com/errata/RHSA-2021:3946

Comment 18 errata-xmlrpc 2021-10-20 14:15:20 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:3945 https://access.redhat.com/errata/RHSA-2021:3945

Comment 19 errata-xmlrpc 2021-10-20 19:44:49 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.1 for RHEL 8
  Red Hat Advanced Cluster Management for Kubernetes 2.1 for RHEL 7

Via RHSA-2021:3949 https://access.redhat.com/errata/RHSA-2021:3949

Comment 20 errata-xmlrpc 2021-10-25 13:17:27 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 10.0 (Newton)

Via RHSA-2021:3971 https://access.redhat.com/errata/RHSA-2021:3971

Comment 21 errata-xmlrpc 2021-10-25 17:56:22 UTC
This issue has been addressed in the following products:

  Red Hat OpenStack Platform 13.0 - ELS
  Red Hat OpenStack Platform 13.0 (Queens) for RHEL 7.6 EUS

Via RHSA-2021:3980 https://access.redhat.com/errata/RHSA-2021:3980

Comment 23 errata-xmlrpc 2021-11-11 18:32:32 UTC
This issue has been addressed in the following products:

  Red Hat Advanced Cluster Management for Kubernetes 2.4 for RHEL 8

Via RHSA-2021:4618 https://access.redhat.com/errata/RHSA-2021:4618


Note You need to log in before you can comment on or make changes to this bug.