Bug 2119763 (CVE-2021-32862) - CVE-2021-32862 nbconvert: arbitrary html injection
Summary: CVE-2021-32862 nbconvert: arbitrary html injection
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-32862
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2119764
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-19 10:54 UTC by Avinash Hanwate
Modified: 2022-09-02 07:56 UTC (History)
2 users (show)

Fixed In Version: nbconvert 6.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-02 07:56:20 UTC


Attachments (Terms of Use)

Description Avinash Hanwate 2022-08-19 10:54:52 UTC
The GitHub Security Lab discovered sixteen ways to exploit a cross-site scripting vulnerability in nbconvert. When using nbconvert to generate an HTML version of a user-controllable notebook, it is possible to inject arbitrary HTML which may lead to cross-site scripting (XSS) vulnerabilities if these HTML notebooks are served by a web server (eg: nbviewer).

https://github.com/jupyter/nbconvert/security/advisories/GHSA-9jmq-rx5f-8jwq
https://github.com/jupyter/nbviewer/security/advisories/GHSA-h274-fcvj-h2wm

Comment 1 Avinash Hanwate 2022-08-19 10:55:13 UTC
Created python-nbconvert tracking bugs for this issue:

Affects: fedora-all [bug 2119764]

Comment 2 Product Security DevOps Team 2022-09-02 07:56:18 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.