Bug 1974728 (CVE-2021-33829) - CVE-2021-33829 ckeditor: cross-site scripting allows remote attackers to inject executable JavaScript code
Summary: CVE-2021-33829 ckeditor: cross-site scripting allows remote attackers to inje...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-33829
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1974730 1974731
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-22 12:10 UTC by Marian Rehak
Modified: 2021-06-22 16:40 UTC (History)
2 users (show)

Fixed In Version: ckeditor 4.16.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-22 16:40:56 UTC
Embargoed:


Attachments (Terms of Use)

Description Marian Rehak 2021-06-22 12:10:12 UTC
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

Reference:

https://ckeditor.com/blog/ckeditor-4.16.1-with-accessibility-enhancements/#improvements-for-comments-in-html-parser

Comment 1 Marian Rehak 2021-06-22 12:11:14 UTC
Created ckeditor tracking bugs for this issue:

Affects: epel-7 [bug 1974731]
Affects: fedora-all [bug 1974730]

Comment 2 Product Security DevOps Team 2021-06-22 16:40:56 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.