Bug 1954232 (CVE-2021-3517) - CVE-2021-3517 libxml2: Heap-based buffer overflow in xmlEncodeEntitiesInternal() in entities.c
Summary: CVE-2021-3517 libxml2: Heap-based buffer overflow in xmlEncodeEntitiesInterna...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-3517
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1956999 1957002 1954233 1954234 1957000 1957001
Blocks: 1952638 1954253
TreeView+ depends on / blocked
 
Reported: 2021-04-27 18:54 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-07-07 19:04 UTC (History)
21 users (show)

Fixed In Version: libxml2 2.9.11
Doc Type: If docs needed, set a value
Doc Text:
There is a flaw in the xml entity encoding functionality of libxml2. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.
Clone Of:
Environment:
Last Closed: 2021-06-29 16:41:02 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:2569 0 None None None 2021-06-29 16:27:45 UTC

Description Guilherme de Almeida Suckevicz 2021-04-27 18:54:09 UTC
A heap-based buffer overflow was found in libxml2 when processing truncated UTF-8 input.

Reference:
https://gitlab.gnome.org/GNOME/libxml2/-/issues/235

Upstream patch:
https://gitlab.gnome.org/GNOME/libxml2/-/commit/bf22713507fe1fc3a2c4b525cf0a88c2dc87a3a2

Comment 1 Guilherme de Almeida Suckevicz 2021-04-27 18:54:40 UTC
Created libxml2 tracking bugs for this issue:

Affects: fedora-all [bug 1954234]


Created mingw-libxml2 tracking bugs for this issue:

Affects: fedora-all [bug 1954233]

Comment 3 Guilherme de Almeida Suckevicz 2021-04-30 12:36:44 UTC
Acknowledgments:

Name: zodf0055980 (SQLab NCTU Taiwan)

Comment 7 Todd Cullum 2021-05-04 22:22:27 UTC
Statement:

This flaw is out of support scope for Red Hat Enterprise Linux 6 and 7. To learn more about Red Hat Enterprise Linux support life cycles, please see https://access.redhat.com/support/policy/updates/errata .

Comment 8 errata-xmlrpc 2021-06-29 16:27:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:2569 https://access.redhat.com/errata/RHSA-2021:2569

Comment 9 Product Security DevOps Team 2021-06-29 16:41:02 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-3517


Note You need to log in before you can comment on or make changes to this bug.