Bug 1964358 (CVE-2021-3569) - CVE-2021-3569 libtpms: stack corruption bug in RSA decryption
Summary: CVE-2021-3569 libtpms: stack corruption bug in RSA decryption
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-3569
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1942902
Blocks: 1964347 1965639
TreeView+ depends on / blocked
 
Reported: 2021-05-25 10:14 UTC by Mauro Matteo Cascella
Modified: 2021-10-29 09:06 UTC (History)
4 users (show)

Fixed In Version: libtpms 0.7.2, libtpms 0.8.0
Doc Type: If docs needed, set a value
Doc Text:
A stack corruption bug was found in libtpms while decrypting data using RSA. This flaw could result in a SIGBUS (bad memory access) and termination of swtpm. The highest threat from this vulnerability is to system availability.
Clone Of:
Environment:
Last Closed: 2021-10-29 09:06:36 UTC


Attachments (Terms of Use)

Description Mauro Matteo Cascella 2021-05-25 10:14:13 UTC
A stack corruption bug was found in libtpms while decrypting data using RSA. The bug exists in CryptRsaDecrypt() in src/tpm2/crypto/openssl/CryptRsa.c. This flaw could cause a SIGBUS (bad memory access) and termination of swtpm.

Upstream commits:
https://github.com/stefanberger/libtpms/commit/505ef841c00b4c096b1977c667cb957bec3a1d8b [v0.8.0]
https://github.com/stefanberger/libtpms/commit/40cfe134c017d3aeaaed05ce71eaf9bfbe556b16 [v0.7.2]

Comment 7 Stefan Berger 2021-10-14 21:15:21 UTC
This bug has been fixed a while ago. I think this bugzilla can be closed.


Note You need to log in before you can comment on or make changes to this bug.