Bug 2019621 (CVE-2021-38503) - CVE-2021-38503 Mozilla: iframe sandbox rules did not apply to XSLT stylesheets
Summary: CVE-2021-38503 Mozilla: iframe sandbox rules did not apply to XSLT stylesheets
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-38503
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2019237 2019238 2019239 2019240 2019241 2019242 2019243 2019244 2019245 2019246 2019247 2019248 2019249 2019250 2019251 2019254 2019255 2019256 2019257 2019258 2019259 2019260 2019362 2019363
Blocks: 2019235
TreeView+ depends on / blocked
 
Reported: 2021-11-03 00:39 UTC by Doran Moppert
Modified: 2021-12-15 08:27 UTC (History)
5 users (show)

Fixed In Version: firefox 91.3, thunderbird 91.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-03 20:07:48 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:4116 0 None None None 2021-11-03 16:03:22 UTC
Red Hat Product Errata RHSA-2021:4123 0 None None None 2021-11-03 19:41:51 UTC
Red Hat Product Errata RHSA-2021:4130 0 None None None 2021-11-04 16:57:13 UTC
Red Hat Product Errata RHSA-2021:4132 0 None None None 2021-11-04 16:55:24 UTC
Red Hat Product Errata RHSA-2021:4133 0 None None None 2021-11-04 16:44:53 UTC
Red Hat Product Errata RHSA-2021:4134 0 None None None 2021-11-04 17:27:19 UTC
Red Hat Product Errata RHSA-2021:4605 0 None None None 2021-11-10 10:35:40 UTC
Red Hat Product Errata RHSA-2021:4607 0 None None None 2021-11-10 09:54:31 UTC

Description Doran Moppert 2021-11-03 00:39:49 UTC
The iframe sandbox rules were not correctly applied to XSLT stylesheets, allowing an iframe to bypass restrictions such as executing scripts or navigating the top-level frame.



External Reference:

https://www.mozilla.org/en-US/security/advisories/mfsa2021-49/#CVE-2021-38503

Comment 1 errata-xmlrpc 2021-11-03 16:03:21 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:4116 https://access.redhat.com/errata/RHSA-2021:4116

Comment 2 errata-xmlrpc 2021-11-03 19:41:50 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4123 https://access.redhat.com/errata/RHSA-2021:4123

Comment 3 Product Security DevOps Team 2021-11-03 20:07:48 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-38503

Comment 4 errata-xmlrpc 2021-11-04 16:44:52 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:4133 https://access.redhat.com/errata/RHSA-2021:4133

Comment 5 errata-xmlrpc 2021-11-04 16:55:23 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:4132 https://access.redhat.com/errata/RHSA-2021:4132

Comment 6 errata-xmlrpc 2021-11-04 16:57:12 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:4130 https://access.redhat.com/errata/RHSA-2021:4130

Comment 7 errata-xmlrpc 2021-11-04 17:27:17 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:4134 https://access.redhat.com/errata/RHSA-2021:4134

Comment 9 errata-xmlrpc 2021-11-10 09:54:30 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:4607 https://access.redhat.com/errata/RHSA-2021:4607

Comment 10 errata-xmlrpc 2021-11-10 10:35:39 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:4605 https://access.redhat.com/errata/RHSA-2021:4605


Note You need to log in before you can comment on or make changes to this bug.