Bug 2021290 (CVE-2021-3927) - CVE-2021-3927 vim: heap-based buffer overflow in gchar_cursor() in misc1.c
Summary: CVE-2021-3927 vim: heap-based buffer overflow in gchar_cursor() in misc1.c
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-3927
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2021291 2021395 2021396
Blocks: 2021294
TreeView+ depends on / blocked
 
Reported: 2021-11-08 18:10 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-11-12 07:33 UTC (History)
18 users (show)

Fixed In Version: vim 8.2.3581
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. A possible heap-based buffer overflow could allow an attacker to input a specially crafted file leading to a crash or code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-11-09 12:24:28 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-11-08 18:10:44 UTC
vim is vulnerable to heap-based buffer overflow.

Reference:
https://huntr.dev/bounties/9c2b2c82-48bb-4be9-ab8f-a48ea252d1b0

Upstream patch:
https://github.com/vim/vim/commit/0b5b06cb4777d1401fdf83e7d48d287662236e7e

Comment 1 Guilherme de Almeida Suckevicz 2021-11-08 18:10:59 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2021291]


Note You need to log in before you can comment on or make changes to this bug.