Bug 2002830 (CVE-2021-40530) - CVE-2021-40530 cryptopp: ElGamal implementation allows plaintext recovery
Summary: CVE-2021-40530 cryptopp: ElGamal implementation allows plaintext recovery
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-40530
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2002832 2002831
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-09 19:28 UTC by Guilherme de Almeida Suckevicz
Modified: 2021-09-10 00:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-10 00:21:17 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-09-09 19:28:56 UTC
The ElGamal implementation in Crypto++ through 8.5 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

References:
https://ibm.github.io/system-security-research-updates/2021/07/20/insecurity-elgamal-pt1
https://ibm.github.io/system-security-research-updates/2021/09/06/insecurity-elgamal-pt2
https://eprint.iacr.org/2021/923

Comment 1 Guilherme de Almeida Suckevicz 2021-09-09 19:29:14 UTC
Created cryptopp tracking bugs for this issue:

Affects: epel-all [bug 2002832]
Affects: fedora-all [bug 2002831]

Comment 2 Product Security DevOps Team 2021-09-10 00:21:17 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.