Bug 2012126 (CVE-2021-41125) - CVE-2021-41125 python-scrapy: information disclosure when using `HttpAuthMiddleware`
Summary: CVE-2021-41125 python-scrapy: information disclosure when using `HttpAuthMidd...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-41125
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2012127
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-08 10:59 UTC by Michael Kaplan
Modified: 2021-10-08 14:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-08 14:08:24 UTC


Attachments (Terms of Use)

Description Michael Kaplan 2021-10-08 10:59:47 UTC
A vulnerability was discovered in python-scrapy. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.


References:

https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6
https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498

Comment 1 Michael Kaplan 2021-10-08 11:00:00 UTC
Created python-scrapy tracking bugs for this issue:

Affects: fedora-all [bug 2012127]

Comment 2 Product Security DevOps Team 2021-10-08 14:08:24 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.