Bug 2035930 (CVE-2021-4173) - CVE-2021-4173 vim: use-after-free with nested :def function
Summary: CVE-2021-4173 vim: use-after-free with nested :def function
Keywords:
Status: NEW
Alias: CVE-2021-4173
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2035931 2035989
Blocks: 2035932
TreeView+ depends on / blocked
 
Reported: 2021-12-28 16:46 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-02-22 06:37 UTC (History)
15 users (show)

Fixed In Version: vim 8.2.3902
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. A possible use after free vulnerability could allow an attacker to input a specially crafted file leading to a crash or code execution.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2021-12-28 16:46:45 UTC
Vim is vulnerable to use-after-free.

Reference:
https://huntr.dev/bounties/a1b236b9-89fb-4ccf-9689-ba11b471e766

Upstream patch:
https://github.com/vim/vim/commit/9c23f9bb5fe435b28245ba8ac65aa0ca6b902c04

Comment 1 Guilherme de Almeida Suckevicz 2021-12-28 16:47:00 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2035931]


Note You need to log in before you can comment on or make changes to this bug.