Bug 2048515 (CVE-2022-0408) - CVE-2022-0408 vim: Stack-based Buffer Overflow in spellsuggest.c
Summary: CVE-2022-0408 vim: Stack-based Buffer Overflow in spellsuggest.c
Keywords:
Status: NEW
Alias: CVE-2022-0408
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On: 2048516 2048528 2048729
Blocks: 2048522
TreeView+ depends on / blocked
 
Reported: 2022-01-31 12:19 UTC by Sandipan Roy
Modified: 2023-07-07 08:29 UTC (History)
16 users (show)

Fixed In Version: vim 8.2.4269
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. The vulnerability occurs due to stack corruption when looking for spell suggestions and leads to a stack buffer overflow. This flaw allows an attacker to input a specially crafted file, leading to a crash or code execution.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Comment 1 Sandipan Roy 2022-01-31 12:20:11 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2048516]

Comment 4 juneau 2022-01-31 17:53:07 UTC
Marking Services affected/delegated/low for presence of affected code.

In the vast majority of cases, the relevant package exists in a container image consumed by the service.
Recommend updating or replacing the container image (to update or remove the package) as appropriate.


Note You need to log in before you can comment on or make changes to this bug.