Bug 2055128 (CVE-2022-0518) - CVE-2022-0518 radare2: Heap-based Buffer Overflow in radare2
Summary: CVE-2022-0518 radare2: Heap-based Buffer Overflow in radare2
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-0518
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2055129 2055130
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-16 10:45 UTC by Vipul Nair
Modified: 2022-03-02 17:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-02 17:51:03 UTC


Attachments (Terms of Use)

Description Vipul Nair 2022-02-16 10:45:53 UTC
Heap-based Buffer Overflow in GitHub repository radareorg/radare2 prior to 5.6.2.

https://github.com/radareorg/radare2/commit/9650e3c352f675687bf6c6f65ff2c4a3d0e288fa
https://huntr.dev/bounties/10051adf-7ddc-4042-8fd0-8e9e0c5b1184

Comment 1 Vipul Nair 2022-02-16 10:46:20 UTC
Created radare2 tracking bugs for this issue:

Affects: epel-all [bug 2055130]
Affects: fedora-all [bug 2055129]

Comment 2 Product Security DevOps Team 2022-03-02 17:51:02 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.