Bug 2067022 (CVE-2022-1115) - CVE-2022-1115 ImageMagick: heap-buffer-overflow in PushShortPixel of quantum-private.h
Summary: CVE-2022-1115 ImageMagick: heap-buffer-overflow in PushShortPixel of quantum-...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2022-1115
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2067098
Blocks: 2064539
TreeView+ depends on / blocked
 
Reported: 2022-03-23 05:17 UTC by TEJ RATHI
Modified: 2022-04-05 19:56 UTC (History)
11 users (show)

Fixed In Version: ImageMagick6 v6.9.12-44, ImageMagick7 v7.1.0-29
Doc Type: If docs needed, set a value
Doc Text:
A heap-buffer-overflow flaw was found in ImageMagick’s PushShortPixel() function of quantum-private.h file. This vulnerability is triggered when an attacker passes a specially crafted TIFF image file to ImageMagick for conversion, potentially leading to a denial of service.
Clone Of:
Environment:
Last Closed: 2022-03-23 14:01:12 UTC


Attachments (Terms of Use)

Description TEJ RATHI 2022-03-23 05:17:12 UTC
A heap-buffer-overflow flaw was found in PushShortPixel function of quantum-private.h

References:
https://github.com/ImageMagick/ImageMagick/issues/4974

Comment 2 TEJ RATHI 2022-03-23 10:07:25 UTC
Created ImageMagick tracking bugs for this issue:

Affects: fedora-all [bug 2067098]


Note You need to log in before you can comment on or make changes to this bug.