Bug 2073973 (CVE-2022-1244) - CVE-2022-1244 radare2: heap-buffer-overflow might cause denial of service.
Summary: CVE-2022-1244 radare2: heap-buffer-overflow might cause denial of service.
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-1244
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2073974 2073975
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-11 09:07 UTC by Marian Rehak
Modified: 2022-04-11 12:08 UTC (History)
2 users (show)

Fixed In Version: radare2 5.6.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-11 12:08:15 UTC


Attachments (Terms of Use)

Description Marian Rehak 2022-04-11 09:07:07 UTC
heap-buffer-overflow in GitHub repository radareorg/radare2 prior to 5.6.8. This vulnerability is capable of inducing denial of service.

Reference:

https://github.com/radareorg/radare2/commit/2b77b277d67ce061ee6ef839e7139ebc2103c1e3
https://huntr.dev/bounties/8ae2c61a-2220-47a5-bfe8-fe6d41ab1f82

Comment 1 Marian Rehak 2022-04-11 09:07:26 UTC
Created radare2 tracking bugs for this issue:

Affects: epel-all [bug 2073975]
Affects: fedora-all [bug 2073974]

Comment 2 Product Security DevOps Team 2022-04-11 12:08:13 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.