Bug 2089218 (CVE-2022-1529) - CVE-2022-1529 Mozilla: Untrusted input used in JavaScript object indexing, leading to prototype pollution
Summary: CVE-2022-1529 Mozilla: Untrusted input used in JavaScript object indexing, le...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2022-1529
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2089203 2089204 2089205 2089206 2089207 2089208 2089209 2089210 2089212 2089234 2089235 2089236 2089237 2089238 2089239 2089240 2089241 2089246
Blocks: 2089201
TreeView+ depends on / blocked
 
Reported: 2022-05-23 09:06 UTC by Mauro Matteo Cascella
Modified: 2022-05-27 23:07 UTC (History)
5 users (show)

Fixed In Version: firefox 100.0.2, firefox 91.9.1, thunderbird 91.9.1
Doc Type: If docs needed, set a value
Doc Text:
The Mozilla Foundation Security Advisory describes this flaw as: An attacker could have sent a message to the parent process where the contents were used to double-index into a JavaScript object, leading to prototype pollution and ultimately attacker-controlled JavaScript executing in the privileged parent process.
Clone Of:
Environment:
Last Closed: 2022-05-27 23:07:24 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2022:4729 0 None None None 2022-05-24 17:46:47 UTC
Red Hat Product Errata RHSA-2022:4730 0 None None None 2022-05-24 16:35:45 UTC
Red Hat Product Errata RHSA-2022:4765 0 None None None 2022-05-27 19:09:04 UTC
Red Hat Product Errata RHSA-2022:4766 0 None None None 2022-05-27 18:52:51 UTC
Red Hat Product Errata RHSA-2022:4767 0 None None None 2022-05-27 02:49:19 UTC
Red Hat Product Errata RHSA-2022:4768 0 None None None 2022-05-27 19:02:45 UTC
Red Hat Product Errata RHSA-2022:4769 0 None None None 2022-05-27 19:25:28 UTC
Red Hat Product Errata RHSA-2022:4770 0 None None None 2022-05-27 18:37:51 UTC
Red Hat Product Errata RHSA-2022:4772 0 None None None 2022-05-27 19:00:22 UTC
Red Hat Product Errata RHSA-2022:4773 0 None None None 2022-05-26 23:21:38 UTC
Red Hat Product Errata RHSA-2022:4774 0 None None None 2022-05-27 02:50:42 UTC
Red Hat Product Errata RHSA-2022:4776 0 None None None 2022-05-27 19:42:45 UTC

Description Mauro Matteo Cascella 2022-05-23 09:06:41 UTC
An attacker could have sent a message to the parent process where the contents were used to double-index into a JavaScript object, leading to prototype pollution and ultimately attacker-controlled JavaScript executing in the privileged parent process.


External Reference:
https://www.mozilla.org/en-US/security/advisories/mfsa2022-19/#CVE-2022-1529

Comment 1 errata-xmlrpc 2022-05-24 16:35:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:4730 https://access.redhat.com/errata/RHSA-2022:4730

Comment 2 errata-xmlrpc 2022-05-24 17:46:45 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:4729 https://access.redhat.com/errata/RHSA-2022:4729

Comment 3 errata-xmlrpc 2022-05-26 23:21:36 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:4773 https://access.redhat.com/errata/RHSA-2022:4773

Comment 4 errata-xmlrpc 2022-05-27 02:49:17 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:4767 https://access.redhat.com/errata/RHSA-2022:4767

Comment 5 errata-xmlrpc 2022-05-27 02:50:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:4774 https://access.redhat.com/errata/RHSA-2022:4774

Comment 6 errata-xmlrpc 2022-05-27 18:37:49 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:4770 https://access.redhat.com/errata/RHSA-2022:4770

Comment 7 errata-xmlrpc 2022-05-27 18:52:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:4766 https://access.redhat.com/errata/RHSA-2022:4766

Comment 8 errata-xmlrpc 2022-05-27 19:00:20 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2022:4772 https://access.redhat.com/errata/RHSA-2022:4772

Comment 9 errata-xmlrpc 2022-05-27 19:02:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:4768 https://access.redhat.com/errata/RHSA-2022:4768

Comment 10 errata-xmlrpc 2022-05-27 19:09:01 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2022:4765 https://access.redhat.com/errata/RHSA-2022:4765

Comment 11 errata-xmlrpc 2022-05-27 19:25:26 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:4769 https://access.redhat.com/errata/RHSA-2022:4769

Comment 12 errata-xmlrpc 2022-05-27 19:42:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:4776 https://access.redhat.com/errata/RHSA-2022:4776

Comment 13 Product Security DevOps Team 2022-05-27 23:07:22 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-1529


Note You need to log in before you can comment on or make changes to this bug.