Bug 2088693 (CVE-2022-1796) - CVE-2022-1796 vim: Use After Free
Summary: CVE-2022-1796 vim: Use After Free
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2022-1796
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2087598
TreeView+ depends on / blocked
 
Reported: 2022-05-20 05:56 UTC by Avinash Hanwate
Modified: 2022-06-09 13:49 UTC (History)
6 users (show)

Fixed In Version: vim 8.2.4979
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. The vulnerability occurs due to Illegal memory access and leads to a use after free vulnerability. This flaw allows an attacker to input a specially crafted file, leading to a crash or code execution.
Clone Of:
Environment:
Last Closed: 2022-06-07 07:49:39 UTC


Attachments (Terms of Use)

Description Avinash Hanwate 2022-05-20 05:56:29 UTC
Use After Free in GitHub repository vim/vim prior to 8.2.

https://github.com/vim/vim/commit/28d032cc688ccfda18c5bbcab8b50aba6e18cde5
https://huntr.dev/bounties/f6739b58-49f9-4056-a843-bf76bbc1253e

Comment 1 Product Security DevOps Team 2022-06-07 07:49:37 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-1796


Note You need to log in before you can comment on or make changes to this bug.