Bug 2116949 (CVE-2022-2047) - CVE-2022-2047 jetty-http: improver hostname input handling
Summary: CVE-2022-2047 jetty-http: improver hostname input handling
Keywords:
Status: NEW
Alias: CVE-2022-2047
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2105401
TreeView+ depends on / blocked
 
Reported: 2022-08-09 15:17 UTC by Patrick Del Bello
Modified: 2022-08-31 22:23 UTC (History)
93 users (show)

Fixed In Version: jetty-http 9.4.47, jetty-http 10.0.10, jetty-http 11.0.10
Doc Type: ---
Doc Text:
A flaw was found in Eclipse Jetty. When parsing the authority segment of an HTTP scheme URI, the Jetty HttpURI class improperly detects an invalid input as a hostname. This issue can lead to failures in a Proxy scenario.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Patrick Del Bello 2022-08-09 15:17:35 UTC
In Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment of an http scheme URI, the Jetty HttpURI class improperly detects an invalid input as a hostname. This can lead to failures in a Proxy scenario.

References:
https://github.com/eclipse/jetty.project/security/advisories/GHSA-cj7v-27pg-wf7q


Note You need to log in before you can comment on or make changes to this bug.