Bug 2103951 (CVE-2022-2264) - CVE-2022-2264 vim: out of bounds read in inc() at misc2.c
Summary: CVE-2022-2264 vim: out of bounds read in inc() at misc2.c
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2022-2264
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2103952
Blocks: 2103257
TreeView+ depends on / blocked
 
Reported: 2022-07-05 11:33 UTC by TEJ RATHI
Modified: 2022-07-05 17:40 UTC (History)
3 users (show)

Fixed In Version: vim 9.0.0011
Doc Type: ---
Doc Text:
A heap buffer overflow vulnerability was found in Vim's inc() function of misc2.c. This issue occurs because Vim reads beyond the end of the line with a put command. This flaw allows an attacker to trick a user into opening a specially crafted file, triggering an out-of-bounds read that causes a crash in the CLI tool.
Clone Of:
Environment:
Last Closed: 2022-07-05 17:40:50 UTC


Attachments (Terms of Use)

Description TEJ RATHI 2022-07-05 11:33:42 UTC
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.

https://huntr.dev/bounties/2241c773-02c9-4708-b63e-54aef99afa6c
https://github.com/vim/vim/commit/d25f003342aca9889067f2e839963dfeccf1fe05

Comment 1 TEJ RATHI 2022-07-05 11:35:21 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2103952]

Comment 2 Product Security DevOps Team 2022-07-05 17:40:48 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-2264


Note You need to log in before you can comment on or make changes to this bug.