Bug 2036898 (CVE-2022-23094) - CVE-2022-23094 libreswan: Malicious IKEv1 packet can cause libreswan to restart
Summary: CVE-2022-23094 libreswan: Malicious IKEv1 packet can cause libreswan to restart
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2022-23094
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2036901 2036902 2036903 2036904 2040149
Blocks: 2036899
TreeView+ depends on / blocked
 
Reported: 2022-01-04 11:17 UTC by msiddiqu
Modified: 2022-05-17 10:01 UTC (History)
4 users (show)

Fixed In Version: libreswan 4.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-24 15:00:41 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2022:0199 0 None None None 2022-01-19 19:29:11 UTC
Red Hat Product Errata RHSA-2022:0239 0 None None None 2022-01-24 14:02:36 UTC

Description msiddiqu 2022-01-04 11:17:32 UTC
A vulnerability was found in libreswan affecting libreswan 4.2 - 4.5, where a malformed packet that is being rejected triggers a logging action that causes a NULL pointer dereference leading to a crash of the pluto daemon.

Comment 2 Huzaifa S. Sidhpurwala 2022-01-13 05:50:09 UTC
Created libreswan tracking bugs for this issue:

Affects: fedora-all [bug 2040149]

Comment 3 Huzaifa S. Sidhpurwala 2022-01-13 05:51:45 UTC
Upstream patches: https://libreswan.org/security/CVE-2022-23094/

Comment 4 Paul Wouters 2022-01-14 18:14:35 UTC
note all fedora releases were fixed before this bug was created.

Comment 5 errata-xmlrpc 2022-01-19 19:29:09 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:0199 https://access.redhat.com/errata/RHSA-2022:0199

Comment 6 errata-xmlrpc 2022-01-24 14:02:34 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:0239 https://access.redhat.com/errata/RHSA-2022:0239

Comment 7 Product Security DevOps Team 2022-01-24 15:00:39 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-23094


Note You need to log in before you can comment on or make changes to this bug.