Bug 2119452 (CVE-2022-24949) - CVE-2022-24949 eternalterminal: Root Privilege Escalation
Summary: CVE-2022-24949 eternalterminal: Root Privilege Escalation
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-24949
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2119461 2119463
Blocks: 2119474
TreeView+ depends on / blocked
 
Reported: 2022-08-18 15:12 UTC by TEJ RATHI
Modified: 2022-09-02 01:55 UTC (History)
3 users (show)

Fixed In Version: et 6.1.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-02 01:55:50 UTC


Attachments (Terms of Use)

Description TEJ RATHI 2022-08-18 15:12:38 UTC
A privilege escalation to root exists in Eternal Terminal prior to version 6.2.0. This is due to the combination of a race condition, buffer overflow, and logic bug all in PipeSocketHandler::listen().

https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-hxg8-4r3q-p9rv
https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3

Comment 1 TEJ RATHI 2022-08-18 15:18:25 UTC
Created et tracking bugs for this issue:

Affects: epel-all [bug 2119461]
Affects: fedora-all [bug 2119463]

Comment 2 Product Security DevOps Team 2022-09-02 01:55:48 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.