Bug 2094997 (CVE-2022-26377) - CVE-2022-26377 httpd: mod_proxy_ajp: Possible request smuggling [NEEDINFO]
Summary: CVE-2022-26377 httpd: mod_proxy_ajp: Possible request smuggling
Keywords:
Status: NEW
Alias: CVE-2022-26377
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2096997 2096998 2096999 2094998
Blocks: 2095023
TreeView+ depends on / blocked
 
Reported: 2022-06-08 19:24 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-07-24 20:16 UTC (History)
49 users (show)

Fixed In Version: httpd 2.4.54
Doc Type: If docs needed, set a value
Doc Text:
An HTTP request smuggling vulnerability was found in the mod_proxy_ajp module of httpd. This flaw allows an attacker to smuggle requests to the AJP server, where it forwards requests.
Clone Of:
Environment:
Last Closed:
icesalov: needinfo? (gsuckevi)


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2022-06-08 19:24:29 UTC
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server 2.4 version 2.4.53 and prior versions.

References:
https://httpd.apache.org/security/vulnerabilities_24.html
https://www.openwall.com/lists/oss-security/2022/06/08/2

Comment 1 Guilherme de Almeida Suckevicz 2022-06-08 19:24:53 UTC
Created httpd tracking bugs for this issue:

Affects: fedora-all [bug 2094998]


Note You need to log in before you can comment on or make changes to this bug.