Bug 2080958 (CVE-2022-28391) - CVE-2022-28391 busybox: remote attackers may execute arbitrary code if netstat is used
Summary: CVE-2022-28391 busybox: remote attackers may execute arbitrary code if netsta...
Keywords:
Status: NEW
Alias: CVE-2022-28391
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2080963
TreeView+ depends on / blocked
 
Reported: 2022-05-02 13:20 UTC by Marian Rehak
Modified: 2022-05-23 12:05 UTC (History)
10 users (show)

Fixed In Version: alpine v 3.15.4
Doc Type: If docs needed, set a value
Doc Text:
An escape sequence injection attack was found in BusyBox on Alpine. For this issue to occur, a remote host's virtual terminal must contain an escape sequence, and the victim must then execute netstat. This flaw allows an attacker can inject arbitrary code, leading to a loss of integrity.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Marian Rehak 2022-05-02 13:20:07 UTC
BusyBox through 1.35.0 allows remote attackers to execute arbitrary code if netstat is used to print a DNS PTR record's value to a VT compatible terminal. Alternatively, the attacker could choose to change the terminal's colors.

Reference:

https://gitlab.alpinelinux.org/alpine/aports/-/issues/13661


Note You need to log in before you can comment on or make changes to this bug.