Bug 2085239 (CVE-2022-28919) - CVE-2022-28919 php-openpsa-universalfeedcreator: cross site scripting vulnerability
Summary: CVE-2022-28919 php-openpsa-universalfeedcreator: cross site scripting vulnera...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-28919
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2085241 2085242 2085243 2085244
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-12 21:05 UTC by Anten Skrabec
Modified: 2022-05-12 23:45 UTC (History)
4 users (show)

Fixed In Version: universalfeedcreator 1.8.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-12 23:45:25 UTC


Attachments (Terms of Use)

Description Anten Skrabec 2022-05-12 21:05:26 UTC
HTMLCreator release_stable_2020-07-29 was discovered to contain a cross-site scripting (XSS) vulnerability via the function _generateFilename.

https://github.com/splitbrain/dokuwiki/issues/3651
https://github.com/flack/UniversalFeedCreator/commit/e4736a68eef454a83acd100230a2e15b424f899f

Comment 1 Anten Skrabec 2022-05-12 21:06:07 UTC
Created dokuwiki tracking bugs for this issue:

Affects: fedora-34 [bug 2085241]
Affects: fedora-35 [bug 2085243]


Created php-openpsa-universalfeedcreator tracking bugs for this issue:

Affects: fedora-34 [bug 2085242]
Affects: fedora-35 [bug 2085244]

Comment 2 Product Security DevOps Team 2022-05-12 23:45:23 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.