Bug 2095012 (CVE-2022-29404) - CVE-2022-29404 httpd: mod_lua: DoS in r:parsebody
Summary: CVE-2022-29404 httpd: mod_lua: DoS in r:parsebody
Keywords:
Status: NEW
Alias: CVE-2022-29404
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2097451 2097452 2097453 2095013
Blocks: 2095023
TreeView+ depends on / blocked
 
Reported: 2022-06-08 19:42 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-06-27 15:48 UTC (History)
48 users (show)

Fixed In Version: httpd 2.4.54
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the mod_lua module of httpd. A malicious request to a Lua script that calls parsebody(0) can lead to a denial of service due to no default limit on the possible input size.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2022-06-08 19:42:15 UTC
In Apache HTTP Server 2.4.53 and earlier, a malicious request to a lua script that calls r:parsebody(0) may cause a denial of service due to no default limit on possible input size.

References:
https://httpd.apache.org/security/vulnerabilities_24.html
https://www.openwall.com/lists/oss-security/2022/06/08/5

Comment 1 Guilherme de Almeida Suckevicz 2022-06-08 19:42:32 UTC
Created httpd tracking bugs for this issue:

Affects: fedora-all [bug 2095013]


Note You need to log in before you can comment on or make changes to this bug.