Bug 2120993 (CVE-2022-2946) - CVE-2022-2946 vim: use after free in function vim_vsnprintf_typval
Summary: CVE-2022-2946 vim: use after free in function vim_vsnprintf_typval
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2022-2946
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2120994 2123649 2123650
Blocks: 2120991
TreeView+ depends on / blocked
 
Reported: 2022-08-24 09:20 UTC by Marian Rehak
Modified: 2022-09-12 11:54 UTC (History)
3 users (show)

Fixed In Version: vim 9.0.0246
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim, where it is vulnerable to a use-after-free in the vim_vsnprintf_typval function. This flaw allows a specially crafted file to crash a program, use unexpected values, or execute code.
Clone Of:
Environment:
Last Closed: 2022-09-12 11:54:47 UTC


Attachments (Terms of Use)

Description Marian Rehak 2022-08-24 09:20:20 UTC
Use After Free in GitHub repository vim/vim prior to 9.0.0245.

Reference:

https://huntr.dev/bounties/5d389a18-5026-47df-a5d0-1548a9b555d5
https://github.com/vim/vim/commit/adce965162dd89bf29ee0e5baf53652e7515762c

Comment 1 Marian Rehak 2022-08-24 09:20:37 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2120994]


Note You need to log in before you can comment on or make changes to this bug.