Bug 2122907 (CVE-2022-3037) - CVE-2022-3037 vim: use after free in function qf_buf_add_line( )
Summary: CVE-2022-3037 vim: use after free in function qf_buf_add_line( )
Keywords:
Status: NEW
Alias: CVE-2022-3037
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2122908 2126336 2126337
Blocks: 2122909
TreeView+ depends on / blocked
 
Reported: 2022-08-31 08:49 UTC by Marian Rehak
Modified: 2022-09-13 14:32 UTC (History)
3 users (show)

Fixed In Version: vim 9.0.0322
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim, where it is vulnerable to a use-after-free in the qf_buf_add_line() function. This flaw allows a specially crafted file to crash a program, use unexpected values, or execute code.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Marian Rehak 2022-08-31 08:49:15 UTC
A use after free in function qf_buf_add_line( ) may cause memory corruption, that can lead to a crash or other undefined (potentially exploitable) behaviour.

Reference:

https://huntr.dev/bounties/af4c2f2d-d754-4607-b565-9e92f3f717b5
https://github.com/vim/vim/commit/4f1b083be43f351bc107541e7b0c9655a5d2c0bb

Comment 1 Marian Rehak 2022-08-31 08:49:28 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2122908]


Note You need to log in before you can comment on or make changes to this bug.