Bug 2094718 (CVE-2022-31212) - CVE-2022-31212 dbus-broker: a stack buffer over-read if a malicious Exec line is supplied
Summary: CVE-2022-31212 dbus-broker: a stack buffer over-read if a malicious Exec line...
Keywords:
Status: NEW
Alias: CVE-2022-31212
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2094721 2102493 2102494 2094720
Blocks: 2094725
TreeView+ depends on / blocked
 
Reported: 2022-06-08 08:58 UTC by Marian Rehak
Modified: 2022-08-17 05:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A stack-based buffer over-read flaw was found in the dbus-broker package. Dbus-Broker depends on c-uitl/c-shquote to parse the DBus service's Exec line, and if a malicious Exec line is supplied, this can lead to a crash or other undefined behaviors.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Marian Rehak 2022-06-08 08:58:29 UTC
Dbus-Broker depends on c-uitl/c-shquote to parse DBus service's Exec line. c-shquote contains a stack buffer over-read if a malicious Exec line is supplied.

Comment 1 Marian Rehak 2022-06-08 08:58:45 UTC
Created dbus-broker tracking bugs for this issue:

Affects: epel-8 [bug 2094721]
Affects: fedora-all [bug 2094720]


Note You need to log in before you can comment on or make changes to this bug.