Bug 2103120 (CVE-2022-33108) - CVE-2022-33108 xpdf: a stack overflow vulnerability via the Object::Copy class of object.cc
Summary: CVE-2022-33108 xpdf: a stack overflow vulnerability via the Object::Copy clas...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-33108
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2103121 2103122
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-07-01 13:43 UTC by Marian Rehak
Modified: 2022-07-02 04:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-02 04:12:42 UTC


Attachments (Terms of Use)

Description Marian Rehak 2022-07-01 13:43:23 UTC
XPDF v4.04 was discovered to contain a stack overflow vulnerability via the Object::Copy class of object.cc files.

https://forum.xpdfreader.com/viewtopic.php?f=3&t=42284
https://forum.xpdfreader.com/viewtopic.php?f=3&t=42286
https://forum.xpdfreader.com/viewtopic.php?f=3&t=42287

Comment 1 Marian Rehak 2022-07-01 13:43:39 UTC
Created xpdf tracking bugs for this issue:

Affects: epel-all [bug 2103121]
Affects: fedora-all [bug 2103122]

Comment 2 Product Security DevOps Team 2022-07-02 04:12:40 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.