Bug 2119650 (CVE-2022-34172) - CVE-2022-34172 Jenkins: Cross-site scripting (XSS) vulnerability in Jenkins LTS
Summary: CVE-2022-34172 Jenkins: Cross-site scripting (XSS) vulnerability in Jenkins LTS
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2022-34172
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2119640
TreeView+ depends on / blocked
 
Reported: 2022-08-19 04:54 UTC by Avinash Hanwate
Modified: 2022-09-02 06:25 UTC (History)
1 user (show)

Fixed In Version: Jenkins 2.356, LTS 2.332.4 and LTS 2.346.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-02 06:25:48 UTC


Attachments (Terms of Use)

Description Avinash Hanwate 2022-08-19 04:54:28 UTC
In Jenkins 2.340 through 2.355 (both inclusive) symbol-based icons unescape previously escaped values of 'tooltip' parameters, resulting in a cross-site scripting (XSS) vulnerability.

https://www.jenkins.io/security/advisory/2022-06-22/#SECURITY-2781

Comment 1 Product Security DevOps Team 2022-09-02 06:25:47 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-34172


Note You need to log in before you can comment on or make changes to this bug.