Bug 2156672 (CVE-2022-3542) - CVE-2022-3542 kernel: A flaw in bnx2x_tpa_stop in drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c lead to memory leak
Summary: CVE-2022-3542 kernel: A flaw in bnx2x_tpa_stop in drivers/net/ethernet/broadc...
Keywords:
Status: NEW
Alias: CVE-2022-3542
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2157003 2157004 2157005 2157006
Blocks: 2136004
TreeView+ depends on / blocked
 
Reported: 2022-12-28 05:16 UTC by Rohit Keshri
Modified: 2023-01-03 13:51 UTC (History)
52 users (show)

Fixed In Version: kernel 6.1 rc1
Doc Type: If docs needed, set a value
Doc Text:
A memory leak flaw was found in bnx2x_tpa_stop in drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c in the bnx2x sub-component in the Linux Kernel. This flaw may allow a local attacker to cause a denial of service.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Rohit Keshri 2022-12-28 05:16:51 UTC
A vulnerability was found in Linux Kernel in bnx2x_tpa_stop in drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c of the component BPF. The manipulation leads to memory leak.

https://git.kernel.org/pub/scm/linux/kernel/git/bpf/bpf-next.git/commit/?id=b43f9acbb8942b05252be83ac25a81cec70cc192
https://vuldb.com/?id.211042


Note You need to log in before you can comment on or make changes to this bug.