Bug 2161310 (CVE-2022-3545) - CVE-2022-3545 kernel: A flaw leading to a use-after-free in area_cache_get()
Summary: CVE-2022-3545 kernel: A flaw leading to a use-after-free in area_cache_get()
Keywords:
Status: NEW
Alias: CVE-2022-3545
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2161314 2161315 2161316 2161317
Blocks: 2161308
TreeView+ depends on / blocked
 
Reported: 2023-01-16 15:14 UTC by Rohit Keshri
Modified: 2023-01-17 19:42 UTC (History)
37 users (show)

Fixed In Version: Kernel 6.0 RC1
Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in area_cache_get in drivers/net/ethernet/netronome/nfp/nfpcore/nfp_cppcore.c in the Netronome Flow Processor (NFP) driver in the Linux kernel. This flaw allows a manipulation that may lead to a use-after-free issue.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Rohit Keshri 2023-01-16 15:14:11 UTC
A vulnerability has been found in area_cache_get in drivers/net/ethernet/netronome/nfp/nfpcore/nfp_cppcore.c in IPsec in the Linux Kernel. The manipulation leads to a use after free problem.

Reference:
https://git.kernel.org/pub/scm/linux/kernel/git/klassert/ipsec-next.git/commit/?id=02e1a114fdb71e59ee6770294166c30d437bf86a


Note You need to log in before you can comment on or make changes to this bug.