Bug 2123233 (CVE-2022-37048) - CVE-2022-37048 tcpreplay: heap-based buffer overflow in get_l2len_protocol at common/get.c
Summary: CVE-2022-37048 tcpreplay: heap-based buffer overflow in get_l2len_protocol at...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-37048
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2123236 2123239
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-09-01 08:00 UTC by TEJ RATHI
Modified: 2022-09-03 15:55 UTC (History)
1 user (show)

Fixed In Version: tcpreplay 4.4.2-beta1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-03 15:55:46 UTC


Attachments (Terms of Use)

Description TEJ RATHI 2022-09-01 08:00:58 UTC
The component tcprewrite in Tcpreplay v4.4.1 was discovered to contain a heap-based buffer overflow in get_l2len_protocol at common/get.c:344. NOTE: this is different from CVE-2022-27941.

https://github.com/appneta/tcpreplay/issues/735

Comment 1 TEJ RATHI 2022-09-01 08:01:20 UTC
Created tcpreplay tracking bugs for this issue:

Affects: epel-all [bug 2123239]
Affects: fedora-all [bug 2123236]

Comment 2 Product Security DevOps Team 2022-09-03 15:55:44 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.