Bug 2134872 (CVE-2022-37599) - CVE-2022-37599 loader-utils: regular expression denial of service in interpolateName.js
Summary: CVE-2022-37599 loader-utils: regular expression denial of service in interpol...
Keywords:
Status: NEW
Alias: CVE-2022-37599
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2134878
Blocks: 2134710
TreeView+ depends on / blocked
 
Reported: 2022-10-14 14:01 UTC by juneau
Modified: 2023-01-04 04:45 UTC (History)
30 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the interpolateName function in interpolateName.js in the webpack loader-utils 2.0.0 via the resourcePath variable in interpolateName.js. This flaw can lead to a regular expression denial of service (ReDoS).
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description juneau 2022-10-14 14:01:44 UTC
A Regular expression denial of service (ReDoS) flaw was found in Function interpolateName in interpolateName.js in webpack loader-utils 2.0.0 via the resourcePath variable in interpolateName.js.

loader-utils prior to version 3 is deprecated and no longer supported

External Reference:
https://github.com/webpack/loader-utils/issues/211


Note You need to log in before you can comment on or make changes to this bug.