Bug 2148169 (CVE-2022-3920) - CVE-2022-3920 consul: Consul Cluster Peering Leaks Imported Nodes/Services Information
Summary: CVE-2022-3920 consul: Consul Cluster Peering Leaks Imported Nodes/Services In...
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2022-3920
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2148174 2148175 2148171 2148172 2148173 2148176
Blocks: 2143395
TreeView+ depends on / blocked
 
Reported: 2022-11-24 13:40 UTC by Avinash Hanwate
Modified: 2022-12-08 04:33 UTC (History)
9 users (show)

Fixed In Version: consul 1.14.0
Doc Type: ---
Doc Text:
A flaw was found in the Consul Package. Affected versions of this package are vulnerable to information exposure via the /v1/internal/ui/nodes and /v1/internal/ui/services endpoints for cluster peering, which expose node and service information to unauthenticated attackers.
Clone Of:
Environment:
Last Closed: 2022-12-08 04:33:07 UTC


Attachments (Terms of Use)

Description Avinash Hanwate 2022-11-24 13:40:28 UTC
HashiCorp Consul and Consul Enterprise 1.13.0 up to 1.13.3 do not filter cluster filtering's imported nodes and services for HTTP or RPC endpoints used by the UI. Fixed in 1.14.0.

https://discuss.hashicorp.com/t/hcsec-2022-28-consul-cluster-peering-leaks-imported-nodes-services-information/46946

Comment 1 Avinash Hanwate 2022-11-24 13:43:49 UTC
Created golang-github-hashicorp-consul-api tracking bugs for this issue:

Affects: fedora-35 [bug 2148171]
Affects: fedora-36 [bug 2148174]


Created golang-github-hashicorp-consul-sdk tracking bugs for this issue:

Affects: fedora-35 [bug 2148172]
Affects: fedora-36 [bug 2148175]


Created moby-engine tracking bugs for this issue:

Affects: fedora-35 [bug 2148173]
Affects: fedora-36 [bug 2148176]

Comment 2 Product Security DevOps Team 2022-12-08 04:33:05 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-3920


Note You need to log in before you can comment on or make changes to this bug.