Bug 2131148 (CVE-2022-39201) - CVE-2022-39201 grafana: Data source and plugin proxy endpoints could leak the authentication cookie to some destination plugins
Summary: CVE-2022-39201 grafana: Data source and plugin proxy endpoints could leak the...
Keywords:
Status: NEW
Alias: CVE-2022-39201
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On: 2131262 2131189 2131190 2133062 2133063 2133064 2134706 2134937
Blocks: 2131159
TreeView+ depends on / blocked
 
Reported: 2022-09-30 05:51 UTC by TEJ RATHI
Modified: 2024-03-02 05:32 UTC (History)
39 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Grafana. The vulnerability impacts data source and plugin proxy endpoints under certain conditions. Grafana could leak the authentication cookie of users to plugins, which could result in an impact to confidentiality, integrity, and availability.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2023:3642 0 None None None 2023-06-15 16:01:10 UTC
Red Hat Product Errata RHSA-2023:6420 0 None None None 2023-11-07 08:16:19 UTC

Description TEJ RATHI 2022-09-30 05:51:39 UTC
CVE-2022-39201: Data source and plugin proxy endpoints could leak the authentication cookie to some destination plugins

Grafana could leak the authentication cookie of users to plugins. The vulnerability impacts data source and plugin proxy endpoints under certain conditions.

Affected versions: Grafana <= 9.1.x

Comment 4 Marian Rehak 2022-10-14 05:37:40 UTC
Created grafana tracking bugs for this issue:

Affects: fedora-all [bug 2134706]

Comment 16 errata-xmlrpc 2023-06-15 16:01:07 UTC
This issue has been addressed in the following products:

  Red Hat Ceph Storage 6.1

Via RHSA-2023:3642 https://access.redhat.com/errata/RHSA-2023:3642

Comment 18 errata-xmlrpc 2023-11-07 08:16:17 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2023:6420 https://access.redhat.com/errata/RHSA-2023:6420


Note You need to log in before you can comment on or make changes to this bug.