Bug 2143645 (CVE-2022-39319) - CVE-2022-39319 freerdp: missing length validation in urbdrc channel
Summary: CVE-2022-39319 freerdp: missing length validation in urbdrc channel
Keywords:
Status: NEW
Alias: CVE-2022-39319
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2143668 2145139 2145140 2143672 2143676 2143677
Blocks: 2143404
TreeView+ depends on / blocked
 
Reported: 2022-11-17 13:37 UTC by TEJ RATHI
Modified: 2022-11-30 03:16 UTC (History)
1 user (show)

Fixed In Version: freerdp 2.9.0
Doc Type: If docs needed, set a value
Doc Text:
An out-of-bound read vulnerability was discovered in FreeRDP due to improper input length validation in client/data_transfer.c in the urbdrc channel. A malicious server can trigger an out-of-bounds read by tricking a FreeRDP based client to read out-of-bound data and send it back to the server.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description TEJ RATHI 2022-11-17 13:37:16 UTC
FreeRDP is a free remote desktop protocol library and clients. Affected versions of FreeRDP are missing input length validation in the `urbdrc` channel. A malicious server can trick a FreeRDP based client to read out of bound data and send it back to the server. This issue has been addressed in version 2.9.0 and all users are advised to upgrade. Users unable to upgrade should not use the `/usb` redirection switch.

https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-mvxm-wfj2-5fvh

Comment 1 TEJ RATHI 2022-11-17 13:51:38 UTC
Created freerdp tracking bugs for this issue:

Affects: fedora-35 [bug 2143672]
Affects: fedora-36 [bug 2143676]
Affects: fedora-37 [bug 2143677]


Created freerdp1.2 tracking bugs for this issue:

Affects: epel-7 [bug 2143668]


Note You need to log in before you can comment on or make changes to this bug.