Bug 2143417 (CVE-2022-43705) - CVE-2022-43705 botan: OCSP response falsification
Summary: CVE-2022-43705 botan: OCSP response falsification
Keywords:
Status: NEW
Alias: CVE-2022-43705
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On: 2143418
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-16 21:33 UTC by Anten Skrabec
Modified: 2023-07-07 08:33 UTC (History)
0 users

Fixed In Version: botan 2.19.3
Doc Type: ---
Doc Text:
Botan 2.19.2 and older failed to verify that an authorized responder certificate embedded in an OCSP response is authorized by the issuing CA. As a result, any valid signature by an embedded certificate passed the check and was allowed to make claims about the revocation status of certificates of any CA.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Anten Skrabec 2022-11-16 21:33:29 UTC
Botan 2.19.2 and older failed to verify that an authorized responder certificate embedded in an OCSP response is authorized by the issuing CA. As a result, any valid signature by an embedded certificate passed the check and was allowed to make claims about the revocation status of certificates of any CA.

Comment 1 Anten Skrabec 2022-11-16 21:33:44 UTC
Created botan2 tracking bugs for this issue:

Affects: fedora-all [bug 2143418]


Note You need to log in before you can comment on or make changes to this bug.