Bug 2143090 (CVE-2022-45379) - CVE-2022-45379 jenkins-plugin/script-security: Whole-script approval in Script Security Plugin vulnerable to SHA-1 collisions
Summary: CVE-2022-45379 jenkins-plugin/script-security: Whole-script approval in Scrip...
Keywords:
Status: NEW
Alias: CVE-2022-45379
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2143096
Blocks: 2143058
TreeView+ depends on / blocked
 
Reported: 2022-11-16 02:48 UTC by Avinash Hanwate
Modified: 2023-01-10 15:10 UTC (History)
3 users (show)

Fixed In Version: Script Security Plugin 1190.v65867a_a_47126
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the script-security Jenkins Plugin. SHA-1 no longer meets the security standards for producing a cryptographically secure message digest. The affected version of the script-security Plugin stores whole-script approvals as the SHA-1 hash of the approved script.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Avinash Hanwate 2022-11-16 02:48:54 UTC
Jenkins Script Security Plugin 1189.vb_a_b_7c8fd5fde and earlier stores whole-script approvals as the SHA-1 hash of the script, making it vulnerable to collision attacks.

https://www.jenkins.io/security/advisory/2022-11-15/#SECURITY-2564


Note You need to log in before you can comment on or make changes to this bug.