Bug 2143086 (CVE-2022-45380) - CVE-2022-45380 jenkins-plugin/JUnit: Stored XSS vulnerability in JUnit Plugin
Summary: CVE-2022-45380 jenkins-plugin/JUnit: Stored XSS vulnerability in JUnit Plugin
Keywords:
Status: NEW
Alias: CVE-2022-45380
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2143094
Blocks: 2143058
TreeView+ depends on / blocked
 
Reported: 2022-11-16 02:37 UTC by Avinash Hanwate
Modified: 2023-01-10 15:10 UTC (History)
3 users (show)

Fixed In Version: JUnit Plugin 1160.vf1f01a_a_ea_b_7f
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the JUnit Jenkins Plugin. The affected version of the JUnit plugin converts HTTP(S) URLs in test report output to clickable links, which leads to a stored Cross-site scripting (XSS) attack.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Avinash Hanwate 2022-11-16 02:37:44 UTC
Jenkins JUnit Plugin 1159.v0b_396e1e07dd and earlier converts HTTP(S) URLs in test report output to clickable links in an unsafe manner, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

https://www.jenkins.io/security/advisory/2022-11-15/#SECURITY-2888


Note You need to log in before you can comment on or make changes to this bug.