Bug 2163691 (CVE-2023-0241) - CVE-2023-0241 pgadmin4: directory traversal vulnerability
Summary: CVE-2023-0241 pgadmin4: directory traversal vulnerability
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2023-0241
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2163692
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-01-24 09:33 UTC by Mauro Matteo Cascella
Modified: 2024-04-17 13:10 UTC (History)
0 users

Fixed In Version: pgadmin 6.19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-01-26 13:22:37 UTC
Embargoed:


Attachments (Terms of Use)

Description Mauro Matteo Cascella 2023-01-24 09:33:25 UTC
pgAdmin 4 versions prior to v6.19 contains a directory traversal vulnerability. A user of the product may change another user's settings or alter the database.

References:
https://jvn.jp/en/jp/JVN01398015/
https://github.com/pgadmin-org/pgadmin4/issues/5734

Comment 1 Mauro Matteo Cascella 2023-01-24 09:33:46 UTC
Created pgadmin4 tracking bugs for this issue:

Affects: fedora-all [bug 2163692]

Comment 2 Product Security DevOps Team 2023-01-26 13:22:35 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.