Bug 2225598 (CVE-2023-29942) - CVE-2023-29942 llvm: convert-spirv-to-llvm Pass trigger Segmentation fault in LLVMStructType verifier
Summary: CVE-2023-29942 llvm: convert-spirv-to-llvm Pass trigger Segmentation fault in...
Keywords:
Status: NEW
Alias: CVE-2023-29942
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On: 2225600 2225601 2225602
Blocks: 2193481
TreeView+ depends on / blocked
 
Reported: 2023-07-25 14:43 UTC by Marian Rehak
Modified: 2023-10-04 17:36 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the llvm package. A segmentation fault via the mlir::Type::isa<mlir::LLVM::LLVMVoidType component may lead to a crash.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Marian Rehak 2023-07-25 14:43:19 UTC
llvm-project commit a0138390 was discovered to contain a segmentation fault via the component mlir::Type::isa<mlir::LLVM::LLVMVoidType.

Reference:

https://github.com/llvm/llvm-project/issues/59990

Comment 1 Marian Rehak 2023-07-25 14:51:38 UTC
Created llvm tracking bugs for this issue:

Affects: fedora-all [bug 2225600]


Note You need to log in before you can comment on or make changes to this bug.