Bug 2213802 (CVE-2023-4155) - CVE-2023-4155 kernel: KVM: SEV-ES / SEV-SNP VMGEXIT double fetch vulnerability
Summary: CVE-2023-4155 kernel: KVM: SEV-ES / SEV-SNP VMGEXIT double fetch vulnerability
Keywords:
Status: NEW
Alias: CVE-2023-4155
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody
QA Contact:
URL:
Whiteboard:
Depends On: 2213805 2213806 2213807 2213808 2229642
Blocks: 2196446
TreeView+ depends on / blocked
 
Reported: 2023-06-09 12:51 UTC by Mauro Matteo Cascella
Modified: 2024-06-12 02:45 UTC (History)
51 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in KVM AMD Secure Encrypted Virtualization (SEV) in the Linux kernel. A KVM guest using SEV-ES or SEV-SNP with multiple vCPUs can trigger a double fetch race condition vulnerability and invoke the `VMGEXIT` handler recursively. If an attacker manages to call the handler multiple times, they can trigger a stack overflow and cause a denial of service or potentially guest-to-host escape in kernel configurations without stack guard pages (`CONFIG_VMAP_STACK`).
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2023:6835 0 None None None 2023-11-09 07:10:58 UTC
Red Hat Product Errata RHBA-2023:7268 0 None None None 2023-11-15 18:24:52 UTC
Red Hat Product Errata RHBA-2023:7328 0 None None None 2023-11-16 11:39:03 UTC
Red Hat Product Errata RHBA-2023:7338 0 None None None 2023-11-16 18:04:25 UTC
Red Hat Product Errata RHBA-2023:7343 0 None None None 2023-11-20 01:58:54 UTC
Red Hat Product Errata RHBA-2023:7346 0 None None None 2023-11-20 09:25:55 UTC
Red Hat Product Errata RHSA-2023:6583 0 None None None 2023-11-07 08:20:31 UTC
Red Hat Product Errata RHSA-2023:6901 0 None None None 2023-11-14 15:15:40 UTC
Red Hat Product Errata RHSA-2023:7077 0 None None None 2023-11-14 15:21:04 UTC
Red Hat Product Errata RHSA-2024:3859 0 None None None 2024-06-12 02:45:08 UTC

Description Mauro Matteo Cascella 2023-06-09 12:51:46 UTC
A KVM guest using SEV-ES or SEV-SNP with multiple vCPUs can trigger a double fetch race condition vulnerability and invoke the `VMGEXIT` handler recursively. If an attacker manages to call the handler multiple times, they can theoretically trigger a stack overflow and cause a denial-of-service or potentially guest-to-host escape in kernel configurations without stack guard pages (`CONFIG_VMAP_STACK`).

Comment 2 Mauro Matteo Cascella 2023-06-09 13:31:42 UTC
RHEL-6 and RHEL-7 kernels are not affected by this flaw as they did not include support for KVM AMD Secure Encrypted Virtualization (SEV).

Comment 3 Mauro Matteo Cascella 2023-06-09 13:41:53 UTC
In reply to comment #0:
> [..] potentially guest-to-host escape in kernel configurations without
> stack guard pages (`CONFIG_VMAP_STACK`).

Note that this kernel option is enabled by default in Red Hat Enterprise Linux 8 and 9.

Comment 9 Mauro Matteo Cascella 2023-08-07 07:30:29 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 2229642]

Comment 10 errata-xmlrpc 2023-11-07 08:20:27 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2023:6583 https://access.redhat.com/errata/RHSA-2023:6583

Comment 11 errata-xmlrpc 2023-11-14 15:15:36 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2023:6901 https://access.redhat.com/errata/RHSA-2023:6901

Comment 12 errata-xmlrpc 2023-11-14 15:21:00 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2023:7077 https://access.redhat.com/errata/RHSA-2023:7077

Comment 17 errata-xmlrpc 2024-06-12 02:45:04 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support
  Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions
  Red Hat Enterprise Linux 8.6 Telecommunications Update Service

Via RHSA-2024:3859 https://access.redhat.com/errata/RHSA-2024:3859


Note You need to log in before you can comment on or make changes to this bug.