Bug 2242239 (CVE-2023-42453) - CVE-2023-42453 matrix-synapse: improper validation of receipts allows forged read receipts
Summary: CVE-2023-42453 matrix-synapse: improper validation of receipts allows forged ...
Keywords:
Status: NEW
Alias: CVE-2023-42453
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2242241
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-10-05 06:10 UTC by TEJ RATHI
Modified: 2023-10-05 06:11 UTC (History)
0 users

Fixed In Version: matrix-synapse 1.93.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description TEJ RATHI 2023-10-05 06:10:57 UTC
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. Users were able to forge read receipts for any event (if they knew the room ID and event ID). Note that the users were not able to view the events, but simply mark it as read. This could be confusing as clients will show the event as read by the user, even if they are not in the room. This issue has been patched in version 1.93.0. Users are advised to upgrade. There are no known workarounds for this issue.

https://github.com/matrix-org/synapse/security/advisories/GHSA-7565-cq32-vx2x
https://github.com/matrix-org/synapse/pull/16327

Comment 1 TEJ RATHI 2023-10-05 06:11:52 UTC
Created matrix-synapse tracking bugs for this issue:

Affects: fedora-all [bug 2242241]


Note You need to log in before you can comment on or make changes to this bug.