Bug 2242151 (CVE-2023-43361) - CVE-2023-43361 vorbis-tools: Buffer Overflow vulnerability
Summary: CVE-2023-43361 vorbis-tools: Buffer Overflow vulnerability
Keywords:
Status: NEW
Alias: CVE-2023-43361
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2242224
Blocks: 2242149
TreeView+ depends on / blocked
 
Reported: 2023-10-04 16:02 UTC by Patrick Del Bello
Modified: 2023-11-10 14:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A buffer overflow vulnerability was found in vorbis-tools. This flaw allows a local attacker to execute arbitrary code and cause a denial of service during the conversion of WAV files to OGG files.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Patrick Del Bello 2023-10-04 16:02:22 UTC
Buffer Overflow vulnerability in Vorbis-tools v.1.4.2 allows a local attacker to execute arbitrary code and cause a denial of service during the conversion of wav files to ogg files.

https://github.com/xiph/vorbis-tools
https://github.com/xiph/vorbis-tools/issues/41
https://github.com/xiph/vorbis
https://xiph.org/vorbis/

Comment 1 Sandipan Roy 2023-10-05 04:22:23 UTC
Created vorbis-tools tracking bugs for this issue:

Affects: fedora-all [bug 2242224]


Note You need to log in before you can comment on or make changes to this bug.